1/25/2024 - Systems Maintenance Outage - Colleague
Incident Report for Bucks County Community College
Postmortem

The issue affecting Colleague/Self Service has been resolved. All systems are available and fully operational.

Posted Jan 26, 2024 - 07:41 EST

Resolved
This incident has been resolved.
Posted Jan 26, 2024 - 07:39 EST
Investigating
ITS is currently investigating an issue with Self Service. We will update with more information as it becomes available.

Thanks for your patience,
Help Desk and Services Center
Posted Jan 25, 2024 - 23:50 EST
This incident affected: Colleague UI.