ITS has completed the MyBucks server reboots. All systems are now available and fully operational.
Thanks, Help Desk and Services Center
Posted Dec 15, 2020 - 11:29 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 15, 2020 - 11:15 EST
Scheduled
We are having ongoing issues with MyBucks and will be performing a emergency reboots of our MyBucks Servers. This will be happening momentarily and it may take about 30 minutes.