10/20/2025 - Systems Outage - Canvas

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:49 EDT

Update

Update - We are continuing to work with AWS looking into our Canvas, Mastery Connect and other Instructure products being down
Oct 20, 2025 - 13:23 MDT
Posted Oct 20, 2025 - 15:44 EDT

Investigating

Canvas is experiencing issues due to an ongoing AWS incident. The Canvas vendor, Instructure, is working on recovering as soon as possible. You can follow the status of the issue at https://health.aws.amazon.com/health/status and https://status.instructure.com/

Thanks,
Help Desk and Services Center
Posted Oct 20, 2025 - 09:34 EDT
This incident affected: Canvas.