7/19/2024 - Widespread Computer Outage
Incident Report for Bucks County Community College
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 12:31 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 20, 2024 - 11:46 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 20, 2024 - 11:45 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2024 - 13:33 EDT
Identified
IT Services is investigating a widespread outage affecting many computers. Please be sure to check https://www.bucks.edu/resources/it/outage/ for updates, as this may require steps from you to resolve.

Thanks,
Help Desk and Services Center
Posted Jul 19, 2024 - 10:54 EDT
Investigating
IT is investigating a widespread outage affecting many computers. Please check back here for updates.
IT Services is investigating a widespread outage affecting many computers. Please be sure to check back here for updates, as this may require steps from you to resolve.
Posted Jul 19, 2024 - 08:45 EDT
This incident affected: Microsoft 365 Applications.