11/1/2024 - Trakdesk Outage
Incident Report for Bucks County Community College
Resolved
This incident has been resolved.
Posted Nov 01, 2024 - 14:24 EDT
Investigating
Trakdesk agents are investigating an issue with opening a ticket using email. Customers attempting to open a ticket in our various Trakdesk tenants using email should email the Help Desk at ict@bucks.edu, Online Learning at, learningresources@bucks.edu, Financial Aid at accounts@bucks.edu, and Research, Assessment, Data Analytics and Reporting at IR@bucks.edu. For any technology related matters, tickets can also be opened by calling the college's Help Desk at 215-968-8191.

Thanks,
Help Desk and Services Center
Posted Nov 01, 2024 - 09:53 EDT
This incident affected: Trakdesk.