1/8/2024 - Workday Service Interruptions
Incident Report for Bucks County Community College
Resolved
This incident has been resolved.
Posted Jan 08, 2024 - 17:52 EST
Investigating
Workday is experiencing some service interruptions causing some users to be unable to access services. ITS is monitoring Workday for updates. The following message pasted below is from the Workday Community Page.

- We are currently working on restoring the homepage to its full experience. Please use the menu options to access the content you are looking for. We apologize for any inconvenience -
Posted Jan 08, 2024 - 13:47 EST
This incident affected: Workday Production.