10/14/2025 - Systems Outage - Bucks WiFi

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 12:53 EDT

Identified

The issue has been identified and a solution will be implemented at noon today. During this implementation WiFi will be unavailable for about 10 minutes.

Thanks,
Help Desk and Services Center
Posted Oct 14, 2025 - 11:37 EDT

Investigating

ITS staff are investigating a campus wide(Newtown) issue with the Bucks WiFi network, wired access is not affected. We are working with our vendor to restore service as quickly as possible. Updates will be posted as soon as they are available.

Thanks,
Help Desk and Services Center
Posted Oct 14, 2025 - 11:04 EDT
This incident affected: WiFi.