ITS staff have completed the MyBucks maintenance ahead of schedule. All systems are available and fully operational.
Thanks, Help Desk and Services Center
Posted Aug 05, 2020 - 21:34 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 05, 2020 - 21:00 EDT
Scheduled
ITS staff will be performing maintenance on the servers that host the MyBucks portal pages. The maintenance will begin at 9:00 p.m. tonight (8/05) and will last for up to one hour. During the maintenance window, MyBucks will be intermittently unavailable. We will send out an all-clear message when the maintenance is complete.