8/4/2020 - Systems Outages -Unable to Login
Incident Report for Bucks County Community College
Resolved
The issues affecting access to our systems have been resolved. Any lingering issues are likely due to either power failures or issues with your Internet Service Provider.

Thanks,
Help Desk and Services Center
Posted Aug 04, 2020 - 15:24 EDT
Investigating
We are experiencing a number of outages this morning related to the storms. As a result access to our systems is spotty. Please be patient as these outages are related to the storms.

Thanks,
Help Desk and Services Center
Posted Aug 04, 2020 - 08:25 EDT
This incident affected: Bucks Website, Canvas, MyBucks - old, MyLab/Mastering, Password Manager, Student Planning, WebAdvisor, Employee Email, Student Email, Network, WiFi, ImageNow, Colleague UI, and OneLogin - SSO Handler.