5/13/2020 - Systems Outage - Office365 - Outlook
Incident Report for Bucks County Community College
Resolved
Microsoft has resolved the issues affecting Office 365 Outlook. All IT services are fully operational and available.

Thanks,
Help Desk and Services Center
Posted May 13, 2020 - 16:14 EDT
Investigating
Microsoft is reporting issues with the Exchange Online service (Office 365 Outlook):

All users may be unable to access the Exchange Online service
EX212990, Exchange Online, Last updated: May 13, 2020 1:53 PM
Start time: May 13, 2020 1:23 PM

Not all users are affected but we've received several reports from the BCCC community of people who are unable to access their emails via the Web. The Outlook desktop client is working.

Microsoft is investigating and has not provided an ETA on resolution.

Thanks,
Help Desk and Services Center
Posted May 13, 2020 - 14:18 EDT
This incident affected: Employee Email and Student Email.