11/2/2023 - Systems Outage - 25 Live
Incident Report for Bucks County Community College
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 13:03 EDT
Investigating
25 Live is currently experiencing issues. The vendor is working to resolve the situation as quickly as possible. At this time 25 Live is unavailable. We will update you as more information becomes available.

Thanks,
Help Desk and Services Center
Posted Nov 02, 2023 - 11:02 EDT