6/2/2025 - System Outage - Voicemail

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 14:55 EDT

Investigating

The college's voicemail system is experiencing service interruptions causing users to be unable to access voicemail. ITS is monitoring this outage for updates.

Thanks,
Help Desk and Services Center
Posted Jun 02, 2025 - 14:41 EDT
This incident affected: Voicemail.