8/27/2024 - Systems Outage - Self Service

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Aug 27, 2024 - 16:49 EDT

Investigating

Self Service is currently experiencing issues. The vendor is working to resolve the situation as quickly as possible.
We will update you as more information becomes available.

Thanks,
Help Desk and Services Center

Check status at bucks.edu/status
Posted Aug 27, 2024 - 15:01 EDT
This incident affected: Student Planning.