8/14/2022 - Systems Outage - Self Service
Incident Report for Bucks County Community College
Resolved
The earlier issues affecting Self Service have been resolved and we've had two instructors report that they were able to successfully enter their grades. Self Service is available and fully operational. We will monitor it throughout the day.

Thanks,
Help Desk and Services Center
Posted Aug 14, 2022 - 11:57 EDT
Investigating
ITS is currently investigating an issue with Self Service. Several instructors have reported that they are unable to enter their grades. We are looking into it and we’ll update you when we have more information.

Thanks for your patience,
Help Desk and Services Center
Posted Aug 14, 2022 - 09:50 EDT
This incident affected: Student Planning.