MyBucks Down

Incident Report for Bucks County Community College

Resolved

MyBucks is now back up and running. Thank you for your patience.
Posted Oct 20, 2020 - 16:14 EDT

Identified

We've identified the problem and are working through a resolution. We expect to be back up and running around 4pm today.
Posted Oct 20, 2020 - 12:57 EDT

Investigating

MyBucks is currently down. ITS is investigating the problem.
Posted Oct 20, 2020 - 08:52 EDT
This incident affected: MyBucks - old.