11/12/2025 - System Outage - Colleague

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 09:25 EST

Investigating

ITS is currently investigating an issue affecting Colleague. At this time Colleague is unavailable. ITS will update this issue when there is a status change.

Thanks,
Help Desk and Services Center
Posted Nov 12, 2025 - 08:26 EST
This incident affected: Colleague UI.