Oct 10, 2024, 1:44 PM EDT Our testing and telemetry indicates that our configuration update has successfully mitigated impact. However, affected users will need to take action to apply the changes we've made and remediate impact:
- Outlook client and app users should restart their client or app to apply our changes.
- Outlook on the web users should refresh their sessions. If that does not mitigate the issue, users are encouraged to clear their browser cache and refresh their Outlook on the web session.
This quick update is designed to give the latest information on this issue.
Posted Oct 10, 2024 - 14:19 EDT
Investigating
Microsoft is reporting issues with their Outlook Desktop app. The following message is from Microsoft; Users may notice Outlook using an increased amount of system resources, causing the client to freeze or crash. Organizations and users with access to Outlook on the web may be able to use that platform as a workaround. While we recognize this workaround may not be viable for all organizations, we would like to offer alternative temporary solutions while we focus on remediation.
Thanks, Help Desk and Services Center
Posted Oct 10, 2024 - 13:13 EDT
This incident affected: Microsoft 365 Applications.