3/18/2025 - Systems Outage - ImageNow

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 12:51 EDT

Investigating

Perceptive Content is investigating a service outage for ImageNow. At this time ImageNow is unavailable. ITS will provide updates as we have news to share.

Thanks,
Help Desk and Services Center
Posted Mar 18, 2025 - 10:10 EDT
This incident affected: ImageNow.