6/27/2025 - Phishing Attempts

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 15:10 EDT

Investigating

ITS is investigating several phishing attempts over the past week. The first involves an email going around with the subject; “Surgery." This email can be deleted as it is a phishing attempt. In addition, there has been a report of text messages being sent by someone presenting themselves as Dr. Jones. If you have received a text message from someone presenting themselves as Dr. Jones or other senior college leadership, please screenshot the message, delete it and report this to ITS immediately.

Thanks, Help Desk and Services Center
Posted Jun 27, 2025 - 13:45 EDT
This incident affected: Phishing Attempt.