3/17/2025 - Workday Service Interruptions

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 09:22 EDT

Investigating

Workday is experiencing some service interruptions causing some users to be unable to access services. ITS is monitoring Workday for updates.

Thanks,
Help Desk and Services Center
Posted Mar 17, 2025 - 14:52 EDT
This incident affected: Workday Production.