5/7/2026 - Systems Maintenance Outage - Canvas

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted May 08, 2026 - 07:04 EDT

Identified

Update - Instructure has placed Canvas, Canvas Beta and Canvas Test in maintenance mode. We anticipate being up soon, and will provide updates as soon as possible
May 07, 2026 - 17:37 MDT
Posted May 07, 2026 - 19:56 EDT

Investigating

The Canvas vendor, Instructure, is reporting Canvas, Canvas Beta and Canvas Test as currently unavailable and under maintenance. Updates will posted as they become available.

Thanks,
Help Desk and Services Center
Posted May 07, 2026 - 18:28 EDT
This incident affected: Canvas.