02/26/2025 - Systems Outage - Slack

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 09:06 EST

Update

Slack update; We're continuing to diligently work on database shard repair and have made progress on restoring affected replicas, though users may still be experiencing impact.

We are continuing to operate urgently to restore full functionality and we appreciate your continued patience.

Feb 26, 4:35 PM EST
Posted Feb 26, 2025 - 16:37 EST

Investigating

Slack is investigating reports of trouble connecting or loading Slack, we'll provide another update once we have news to share.

Thanks,
Help Desk and Services Center
Posted Feb 26, 2025 - 10:59 EST
This incident affected: Slack.