3/17/2026 - System Outage - Asset Essentials/Brightly

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 11:44 EDT

Investigating

The following message appears on the Brightly status page at https://status.brightlysoftware.com/

Investigating - Our team is currently investigating an issue impacting access to Asset Essentials. This is a top priority for our team and we hope to have a resolution soon. We apologize for the inconvenience and will continue to post updates on this page.
Mar 17, 2026 - 09:48 EDT

Thanks,
Help Desk and Services Center
Posted Mar 17, 2026 - 10:32 EDT
This incident affected: Brightly.