12/7/2024 Phishing Attempts
Incident Report for Bucks County Community College
Resolved
This incident has been resolved.
Posted Dec 18, 2024 - 09:33 EST
Investigating
ITS is investigating several phishing attempts. Any email with the subject; "Email System Maintenance" can be deleted. Please report emails with those subjects and any other suspicious emails to ITS. As a reminder, BCCC ITS will never send an email asking faculty, staff or students to fill out personal information, or information about your account.
Posted Dec 07, 2024 - 10:18 EST
This incident affected: Employee Email and Student Email.