8/28/2025- System Outage - Incontact

Incident Report for Bucks County Community College

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 17:40 EDT

Investigating

The college's call center system Incontact, is experiencing service interruptions causing users to be unable to access the college's Help Desk and various call centers by phone. ITS is monitoring this outage for updates. For immediate Help Desk service, please email the Help Desk at help.desk.bucks.edu.

Thanks,
Help Desk and Services Center
Posted Aug 28, 2025 - 17:16 EDT
This incident affected: Incontact.