4/16/2025 - Systems Outage - Zoom

Incident Report for Bucks County Community College

Resolved

All Zoom services have been restored and are available to users. If you continue to experience issues with service please contact the college's Help Desk at help.desk@bucks.edu.
Posted Apr 16, 2025 - 17:35 EDT

Investigating

Zoom is experiencing some service interruptions causing users to be unable to access services. ITS is monitoring Zoom for updates. As a reminder, Teams is available for all Fac/Staff/Students. Microsoft Teams Meetings is also available in Canvas for all instructors to use with students in their Canvas course spaces if necessary.

Thanks,
Help Desk and Services Center
Posted Apr 16, 2025 - 15:23 EDT
This incident affected: Zoom.