03-14-18 - Service Alert - MyBucks
Incident Report for Bucks County Community College
Resolved
The MyBucks certificate issue has been resolved. If you're continuing to experience issues, please contact the Help Desk - 215-968-8191 or help.desk@bucks.edu.

Thanks,
Help Desk and Services Center
Posted 6 months ago. Mar 14, 2018 - 08:54 EDT
Identified
Users attempting to access MyBucks will see a Security Certificate warning. ITS is updating the Security Certificate but it will be a little while before that completely takes effect. In the meantime, users can click through the warning messages and proceed to the site. Chrome users will click on the Advanced link and then click on Proceed to site. Other browsers will exhibit similar behavior.

If you have any questions, please contact the Help Desk - 215-968-8191 or help.desk@bucks.edu.

Thanks,
Help Desk and Services Center
Posted 6 months ago. Mar 14, 2018 - 08:23 EDT