11/22/2024 - Canvas Outage
Incident Report for Bucks County Community College
Resolved
This incident has been resolved.
Posted Nov 22, 2024 - 13:52 EST
Update
We are continuing to investigate this issue.
Posted Nov 22, 2024 - 13:52 EST
Investigating
The Canvas vendor is investigating a systems issue and working to resolve it. Updates will follow as they are available.

https://status.instructure.com/

Thank for your patience,
Help Desk and Services Center
Posted Nov 22, 2024 - 12:25 EST
This incident affected: Canvas.