2/13/2024 - Canvas Outage
Incident Report for Bucks County Community College
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 12:42 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 13, 2024 - 12:24 EST
Investigating
The Canvas vendor is investigating a systems issue and working to resolve it. Updates will follow as they are available.
Posted Feb 13, 2024 - 12:19 EST
This incident affected: Canvas.