02/01/18 - Service Interruption - MyBucks
Incident Report for Bucks County Community College
Resolved
ITS has resolved the issue affecting MyBucks access. MyBucks is now fully operational and available.

Thanks for your patience,
Hep Desk and Services Center
Posted 11 months ago. Feb 01, 2018 - 09:24 EST
Identified
MyBucks is currently unavailable. ITS staff are aware of the issue and working on a resolution. We will update status as further information becomes available.

Thanks,
Help Desk and Services Center
Posted 11 months ago. Feb 01, 2018 - 08:11 EST