3/29/18 - Service Interruption - Web Site Issues
Incident Report for Bucks County Community College
Resolved
The Bucks.edu website has been recovered and all pages are now displaying properly.

Thanks,
Help Desk and Services Center
Posted 4 months ago. Mar 29, 2018 - 16:15 EDT
Investigating
A number of pages on the Bucks website are not displaying any content. ITS is investigating and will provide an update when we have more information to share.

Thanks,
Help Desk and Services Center
Posted 4 months ago. Mar 29, 2018 - 15:30 EDT