4/19/18 - System Outage - MyBucks
Incident Report for Bucks County Community College
Resolved
ITS staff have resolved the issue affecting access to MyBucks and all IT Services are available and fully operational.

Thanks for your patience,
Help Desk and Services Center
Posted 5 months ago. Apr 19, 2018 - 08:32 EDT
Investigating
The MyBucks portal is currently unavailable. ITS is investigating the issue and working on restoring the system. Working resources usually accessed via the Portal page can be accessed
using the following links:

Colleague/Datatel (staff only)- https://webui5.bucks.edu:444/production_ui46/index.htm

Mail or Office 365 applications - portal,office.com
Faculty & Staff would have to use regular username & password
Students would have to use username@live.bucks.edu

Canvas - https://bucks.instructure.com/login

Student Planning - https://selfservice.bucks.edu/Student/Account/login

Password Manager - http://www.bucks.edu/e-resources/password/

Web Advisor - type in address bar… pebbles.bucks.edu

Updates will be provided as additional information becomes available.

Thanks for your patience,
Help Desk and Services Center
Posted 5 months ago. Apr 19, 2018 - 07:49 EDT