5/16 - Login Issues
Incident Report for Bucks County Community College
Resolved
The earlier issues affecting logging in to Bucks' systems have been fixed. If you happen to receive an error when attempting to log in, please try again. It may take a little time for the fix to populate across all systems.

Thanks for your patience,
Help Desk and Services Center
Posted 4 months ago. May 16, 2017 - 20:36 EDT
Investigating
Some users are experiencing login issues. The message they see is that their password is invalid. This issue is occurring sporadically. ITS has contacted our vendor and they are investigating the issue. If you experience this issue, please try logging in again. If it fails again, wait a few minutes and try again. It may take several tries before you’re able to get in.

We apologize for any inconvenience this may cause you. We are working with the vendor to get full functionality restored as soon as possible.

Thanks,
Help Desk and Services Center
Posted 4 months ago. May 16, 2017 - 15:53 EDT