11/21 - Systems Outage - MyBucks Portal
Incident Report for Bucks County Community College
Resolved
The earlier issues affecting the MyBucks portal have been resolved. If you experience any issues logging into MyBucks, please contact the Help Desk @8191 or help.desk@bucks.edu.

Thanks,
Help Desk and Services Center
Posted 3 months ago. Nov 21, 2017 - 10:02 EST
Investigating
The MyBucks portal is currently down. ITS staff are working on a resolution.

We will update this announcement as more information becomes available.

Thanks,
Help Desk and Services Center
Posted 3 months ago. Nov 21, 2017 - 09:39 EST