1/25/18 - Colleague and Related Applications Service Interruption
Incident Report for Bucks County Community College
Resolved
ITS has resolved the earlier issues affecting Colleague and its related applications. All services are fully operational and available. If you're experiencing any issues, please contact the Help Desk - help.desk@bucks.edu or 215-968-8191.

Thanks
Help Desk and Services Center
Posted 10 months ago. Jan 25, 2018 - 08:31 EST
Investigating
Colleague and related applications including Self Service for Faculty. Students and Staff is down. ITS is working on a resolution and we will provide updates as additional information becomes available.
Posted 10 months ago. Jan 25, 2018 - 08:05 EST